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Introductions

GitHub Copilot is an AI-powered code completion tool developed by GitHub in collaboration with OpenAI. It is built on the GPT (Generative Pre-trained Transformer) architecture, the same technology behind ChatGPT, and is designed to assist developers in writing code more efficiently.

Key Features

Here's are its key features: 

• Code Completion: GitHub Copilot provides intelligent code completion suggestions as you type, helping you write code faster and reducing the need to remember syntax or boilerplate code.
• Contextual Suggestions: Copilot analyses the code context, including function names, variable names, and comments, to generate relevant code suggestions tailored to your specific coding task.
• Support for Multiple Languages: Copilot supports a wide range of programming languages, including Python, JavaScript, TypeScript, Ruby, Go, and many more.
• Code Understanding: GitHub Copilot can understand the intent behind your code and generate accurate and relevant suggestions based on that understanding. It can also provide explanations for the suggested code snippets.
• Code Examples: Copilot can generate entire code snippets or functions based on a description of what you're trying to achieve. This is particularly helpful when starting a new project or implementing a new feature.
• Error Handling: GitHub Copilot can help you catch errors by suggesting fixes or providing examples of how to handle specific error scenarios.
• Integration with IDEs: GitHub Copilot integrates seamlessly with popular code editors such as Visual Studio Code (VS Code), Intellij Idea, Pycharm etc, making it easy to use within your existing development workflow.
• Learning and Improvement: GitHub Copilot learns from the code it encounters and the feedback it receives from developers, continually improving its suggestions over time.
• Privacy and Security: GitHub Copilot prioritizes privacy and security by ensuring that the code you write remains private to you and your team. It does not store or share your code with anyone else.

Overall, GitHub Copilot aims to enhance developer productivity by providing intelligent code suggestions, improving code quality, and reducing the time spent on repetitive coding tasks. However, it's important to note that while Copilot can be a valuable tool, it's not a substitute for understanding programming concepts or writing code from scratch. Developers should always review and verify the code suggestions provided by Copilot to ensure correctness and maintainability.

How to get the most out of GitHub Copilot!

Here are some key strategies and tips:
Mastering the Basics: 

o Get comfortable with the interface: Familiarize yourself with how Copilot presents suggestions, accepts/rejects them, and offers different options. Learn keyboard shortcuts for faster interaction.

o Understand its capabilities and limitations: Copilot excels at suggesting code snippets, boilerplate, and common patterns. Don't expect it to write entire functions or solve complex algorithms.

o Provide clear context: The more specific you are about your code's purpose, function, and surrounding structure, the better Copilot can tailor its suggestions. Use comments, variable names, and function names effectively.

o Experiment and iterate: Don't be afraid to try different suggestions and see what works best. The more you use Copilot, the better it understands your coding style and preferences.

Advanced Techniques: 

o Leverage temperature settings: Adjust the temperature slider to control the risk/reward ratio of suggestions. Higher temperatures offer more creative but potentially less accurate options.

o Fine-tune acceptance rules: Configure Copilot to only accept suggestions that meet specific criteria, like passing type checks or adhering to coding conventions.

o Utilize safety features: Enable safety features like duplication detection and code quality checks to ensure your code remains secure and maintainable.
o Explore custom configurations: If you use a specific coding style guide or framework, explore custom settings to align Copilot's suggestions with those standards.
Beyond the Basics:

o Learn from its suggestions: Analyze accepted suggestions to understand the patterns and approaches Copilot uses. This can improve your own coding skills.

o Contribute to the GitHub Copilot dataset: If you find Copilot's suggestions helpful, consider contributing code or data to improve its training and benefit the wider developer community.

o Engage with the community: Join forums, discussions, and tutorials to learn from other Copilot users, share experiences, and get tips and tricks. Remember: 

o Copilot is a tool, not a replacement: Use Copilot to augment your own coding abilities, not to replace them. Understand the code it generates and maintain control over your projects.

o Responsible use is crucial: Be mindful of potential biases or limitations in Copilot's suggestions. Use it ethically and responsibly to avoid generating harmful or unfair codes.

Notepad to AI

[image: ]

The progression from Notepad to IntelliJ IDEA with GitHub Copilot represents a significant evolution in the tools available to programmers, offering increasingly sophisticated features and capabilities:
Notepad: Notepad is a basic text editor that provides minimal functionality for writing code. While it can be used for simple tasks, it lacks features tailored for programming, such as syntax highlighting, code completion, and debugging tools. Programmers using Notepad often face challenges in managing larger projects and debugging errors efficiently.
Notepad++: Notepad++ is an improvement over Notepad, offering enhanced features like syntax highlighting, code folding, and customizable themes. It provides a more comfortable environment for coding compared to Notepad, but it still lacks advanced features found in dedicated integrated development environments (IDEs), such as project management and version control integration.
Eclipse: Eclipse is a popular Java IDE known for its comprehensive set of features, including syntax highlighting, code completion, debugging, refactoring tools, and support for various programming languages through plugins. Eclipse significantly improves productivity for programmers, offering an integrated environment for writing, testing, and debugging code. However, it can be resource-intensive and complex for beginners.
IntelliJ IDEA: IntelliJ IDEA is a powerful and user-friendly IDE that builds upon the features of Eclipse while providing additional enhancements such as better performance, smarter code completion, advanced refactoring tools, and seamless integration with build systems and version control. IntelliJ IDEA streamlines development workflows, improves code quality, and offers a more intuitive user experience compared to Eclipse.
IntelliJ IDEA with GitHub Copilot: Integrating GitHub Copilot with IntelliJ IDEA further enhances the development experience by leveraging artificial intelligence to assist programmers in writing code. GitHub Copilot provides intelligent code suggestions, autocompletions, and even generates entire code snippets based on context, significantly reducing manual effort, and accelerating development tasks. This integration augments the capabilities of IntelliJ IDEA, empowering programmers to write code more efficiently, explore innovative solutions, and improve productivity. In summary, the progression from Notepad to IntelliJ IDEA with GitHub Copilot represents a journey of increasing sophistication and efficiency in the tools available to programmers, enabling them to write high-quality code more effectively and tackle complex programming tasks with greater ease

How Copilot Works

Below diagram shows how copilot works
[image: ]

OpenAI Codex is an AI model developed by OpenAI. Codex was trained on a vast amount of code from various sources, including open-source repositories, to understand and generate code in multiple programming languages. It was built on the GPT (Generative Pre-trained Transformer) architecture, similar to the one used in models like GPT-3.

Codex was particularly notable for its ability to understand and generate code based on natural language prompts. It could be used for tasks such as code completion, code generation, and even assisting developers in writing software.

So basically, on right side when you try to write code and give any actions like providing context, suggestions or asking questions then request goes to Github Copilot Service which indirectly calls codex model and based on the training model it gives the response...

Set up GitHub Copilot

Set up GitHub Copilot on Visual Studio Code

To set up GitHub Copilot in Visual Studio Code (VS Code), follow these steps:
• Install Visual Studio Code: If you have not already, download and install Visual 

Studio Code from the official website: Visual Studio Code.
• Install GitHub Copilot Extension: Open VS Code and navigate to the Extensions 
view by clicking on the square icon on the sidebar or pressing Ctrl+Shift+X. Search
for "GitHub Copilot" in the Extensions Marketplace and install it.
• Sign in to GitHub: After installing the GitHub Copilot extension, you'll need to sign
in to your GitHub account. Click on the "Sign in" button in the GitHub Copilot
extension's panel and follow the prompts to sign in to your GitHub account.
• Authenticate GitHub Copilot: Once signed in, GitHub Copilot may ask you to
authenticate your account. Follow the instructions provided to complete the
authentication process.
• Set Up GitHub Copilot Settings: You can configure GitHub Copilot settings 
according to your preferences. To access the settings, click on the gear icon in the
GitHub Copilot panel or go to File > Preferences > Settings (or press Ctrl+,). Search
for "GitHub Copilot" in the settings search bar to find and configure Copilot
settings.
• Enable Copilot: Make sure GitHub Copilot is enabled by default. You can confirm
this by checking the status in the GitHub Copilot panel.
• Start Using GitHub Copilot: With GitHub Copilot installed and configured, you 
can start using it in your code editing sessions. As you type, GitHub Copilot will 
provide code suggestions and completions based on the context of your code.

Remember that GitHub Copilot learns from the code it encounters and improves over time. Feel free to provide feedback on the suggestions it provides to help it become even more effective.

That's it! You've successfully set up GitHub Copilot in Visual Studio Code and are ready to leverage its AI-powered code suggestions to enhance your coding experience. 

Set up GitHub Copilot on IntelliJ Idea

Setting up GitHub Copilot on IntelliJ IDEA involves two main steps: installing the plugin and configuring it. Here's how:
Installation: 

1. Open IntelliJ IDEA.
2. Go to Settings > Plugins.
3. Search for "GitHub Copilot" in the Marketplace.
4. Click "Install" and wait for the installation to complete.
5. Restart IntelliJ IDEA.

Configuration: 

6. Go to Settings > Languages & Frameworks > GitHub Copilot.
7. Sign in to your GitHub account.
8. Optionally, adjust the settings:
o Template suggestions: Control how many suggestions Copilot shows and their likelihood of being relevant.
o Filter: Exclude specific libraries or frameworks from suggestions. o Privacy: Adjust telemetry settings.
9. Click "Apply" to save your changes.

Additional notes: 

• Currently, GitHub Copilot Chat is in beta for JetBrains IDEs. This means that only a limited number of users have access, and the features might be subject to change. You can check if you're eligible for the beta on the GitHub Copilot website.
• GitHub Copilot requires a subscription. You can get a free trial or purchase a subscription on the GitHub website.

Set up GitHub Copilot on Pycharm

Prerequisites:
• A PyCharm Professional subscription (Copilot is currently not included in the Community edition).
• A GitHub account (free or paid).
Installation: 

10. Open PyCharm and go to File > Settings (Windows/Linux) or PyCharm > Preferences (macOS).
11. In the Settings/Preferences dialog, navigate to Plugins.
12. In the Marketplace tab, search for GitHub Copilot.
13. Click Install and then Restart PyCharm when prompted.
14. After restarting PyCharm, you'll see a GitHub Copilot notification. Click it and follow the on-screen instructions.
15. You'll be prompted to Sign in to GitHub. Enter your credentials.
16. Review and accept the Terms of Service.
17. Choose your preferred usage plan. If you're using a free GitHub account, select the Free plan. This plan has a limited quota of generated code per month.

Configuration (Optional): 

18. To customize Copilot's behavior, go to Settings/Preferences > Languages & Frameworks > GitHub Copilot.
19. Here you can:
o Enable or disable Copilot suggestions.
o Adjust the suggestion placement (e.g., inline or in a separate tab). o Set a keyboard shortcut for accepting suggestions.
o Configure the server-side temperature and top settings for more control over generated code.

Getting hands-on

Example with Intellij Idea
Creating a New Project

Creating a new project in IntelliJ IDEA is straightforward. Here's a step-by-step guide: 

• Open IntelliJ IDEA: Launch IntelliJ IDEA on your computer. You can do this by double-clicking the IntelliJ IDEA icon on your desktop or finding it in your Start menu.
• Open the Welcome Screen: Once IntelliJ IDEA is launched, you'll see the Welcome screen. If you're already working on a project, you can close it to get back to the Welcome screen. If the Welcome screen is not visible, you can access it by clicking on "File" > "Close Project".
• Create a New Project:

o On the Welcome screen, click on the "New Project" button. Alternatively, you can also go to "File" > "New" > "Project..." from the menu bar.
o This will open the New Project wizard.
• Choose Project Type:
o In the New Project wizard, you'll be prompted to select the type of project you want to create. Choose the appropriate project type based on your requirements. For example, you can select "Java" for a Java project, "Maven" for a Maven project, "Gradle" for a Gradle project, etc.
o After selecting the project type, click "Next".
• Configure Project:
o In the next step, you'll need to configure your project settings such as project name, project location, project SDK (Java version), and any additional settings specific to the chosen project type.
o Make sure to provide meaningful names and appropriate locations for your project.
o Once you've configured the project settings, click "Next".
• Finish:
o Review the project summary to ensure all settings are correct.
o Click "Finish" to create the project.
• Wait for Project Creation:
o IntelliJ IDEA will create the project based on the specified settings. This might take a few moments depending on your system's speed and the complexity of the project.
• Start Coding:
o Once the project is created, you'll be taken to the IntelliJ IDEA workspace with your new project loaded.
o You can start coding by creating new classes, packages, or files within your project.
That's it! You have successfully created a new project in IntelliJ IDEA. You can now start working on your project and building your application.

For example, while creating new Project e.g GithubCopilotExamples will have below windows
[image: ][image: ]

Click on New Window if you want it as separate window. To confirm whether Github Copilot is installed click in file-> settings,(search for plugin) and you can get below window where github copilot will appear in plugins.

[image: ]After clicking the OK button check in Tool-> Github copilot.
You will get all options from Github copilot as shown in below screenshot 

Hello World Using Github Copilot Open Github Copilot Chat from Right side panel and try the prompt question as shown in below picture.

[image: ]

Then press Enter and you can see answer as below

[image: ]

Example with Intellij Idea
Creating a New Project

To create a new project in PyCharm, follow these steps: 

o Open PyCharm: Launch PyCharm from your desktop shortcut or from the Start menu.
o Welcome Screen: You'll be greeted with the PyCharm welcome screen. From here, you can either create a new project or open an existing one. Click on "Create New Project" to start a new project.
o Choose Project Interpreter: In the "New Project" dialog, you'll need to choose a Python interpreter for your project. If you have one already configured, it will appear in the dropdown list. If not, you can click on the gear icon to configure a new interpreter. Once you've selected an interpreter, click "Create".
o Project Location: Next, you'll be prompted to choose a location for your project on your file system. You can either accept the default location or choose a custom one. After selecting the location, click "Create".
o Project Setup: PyCharm will now create the project structure and set up the necessary files for your new project.
o Explore Your Project: Once the project is created, you'll see it open in the PyCharm IDE. From here, you can start adding files, writing code, and organizing your project structure.
o Customize Project Settings (Optional): You can customize various project settings such as interpreter, project interpreter, project structure, version control, and more from the settings/preferences menu. Simply go to "File" > "Settings" (Windows/Linux) or "PyCharm" > "Preferences" (macOS) to access these options.
That's it! You've successfully created a new project in PyCharm and are ready to start coding. You can now begin writing Python code, adding files, and building your project using the features and tools provided by PyCharm.

Lets see using UI steps
Open Pycharm File->new Project
[image: ]

Give name of the project and location of the project in you working dir and click on create and choose This Window if you want to create project in the same window or select New Window if you want to create project in a new window

[image: ]I will choose New Window and screen will look like below
[image: ]

Select Tools-> Github copilot like below where you will see all options

[image: ]

I am already login but if you are using first time and you can find the login to Github and to authorize. Once login completed you can start using github copilot and you can see Github Copilot Chat on the right side panel bar as below.

[image: ]Try with simple prompt “Write a hello world program in python” like below and you will get answers as below in chat window. 

Using comments in editor

One way is as shown in below editor just write a comment and ask what you want to do.Press enter and in next line you will get the suggested answers, if you like it then press tab and the code will be inserted.

[image: ]

Ask question in github copilot chat

Ask question in github copilot chat to write a code and use the icons in chat to insert code into editor as below 

Code Review with Github Copilot

GitHub Copilot has the potential to be a valuable tool in the code review process, offering several benefits to both developers and reviewers: 

Copilot can suggest code snippets that adhere to best practices and coding standards, helping to improve the overall quality and maintainability of your code. It can also point out potential errors or inefficiencies, prompting you to review and improve your code before submitting a pull request.

Let see example using Python 

Function name code review

[image: ]And then try in github copilot chat with below question
[image: ]Then you may get below answer and code block with sugggested code [image: ]

Variable name code review

[image: ]Then try below in Github Copilot chat
Please review the code and give suggestions [image: ][image: ]

List of Commands reference

(COMMANDS ARE DIFF WITH DIFF TOOLS LIKE VSCODE,PYCHARM AND INTELLIJ, JUST USE @ AND/ THEN CHECK WHICH COMMANDS ARE AVAILABLE E.G IN VSCODE
[image: ]

Agents and slash commands

Wiht Github Copilot you can indicate the scope and intent of your question through agents and slash commands.
Agents are like experts who have a specialty that they can help you with, and you can talk to them in the chat by mentioning them with the @ symbol. Currently, there are two agents: 

o @workspace has context about the code in your workspace and can help you navigate it, finding relevant files or classes.
o @vscode knows about commands and features in the VS Code editor itself, and can help you use them.
o @terminal has context about the integrated terminal shell and its contents.

----------------------------------------------------------------------------------------------------------------

o @workspace /explain: Explain step-by-step how the selected code works. o @workspace /fix: Propose a fix for the bugs in the selected code. o @workspace /new: Create a new project based on a natural language

description.
o @workspace /newNotebook: Create a new Jupyter Notebook based on your 
description.
o @workspace /tests: Generate unit tests for the selected code. o @vscode /api: Questions about VS Code extension development. o @terminal: Explain how to do something in the integrated terminal. o /help: Prints general help about GitHub Copilot.
o /clear: Clear the session

GitHub Copilot CLI: Your AI companion in the terminal

GitHub Copilot CLI brings the power of AI code completion directly to your terminal, helping you write commands and scripts faster and more efficiently. Here's what you need to know:

What it is:
o An extension that integrates Copilot with your command-line interface. o Provides suggestions for commands, flags, and even entire scripts based on your context.
o Can be used with various shells like Bash, Zsh, and Fish.
Benefits:
o Increased productivity: Write code faster and with fewer errors. o Improved command recall: Get suggestions for commands you might have forgotten.
o Discover new possibilities: Explore different ways to achieve your goals with suggested commands.
Getting started:
o Prerequisites:
▪ A GitHub account with Copilot enabled (free trial available). ▪ A supported terminal emulator.
o Installation:
i. Authenticate with GitHub: gh auth login
ii. Install Copilot CLI: gh extension install github/gh-copilot iii. Restart your terminal.
Usage: 

o Simply type your starting command or partial script in the terminal. o Copilot will suggest completions based on your context.
o Use the arrow keys to navigate and Tab to accept a suggestion. o You can also customize Copilot's behavior with flags and configuration.

Github Cli Installation

[image: ]

Prompts

In generative AI, prompts are like the instructions or questions you give to an AI model to get it to create something new. Imagine it as the starting point for a conversation, guiding the AI towards your desired outcome. Here's a breakdown of their role:

What they do: 

o Specify the task: Prompts tell the AI what you want it to do. Do you want it to write a poem, translate a text, or write a line of code? The prompt sets the direction.

o Provide context: They give the AI information to work with. This could be specific details like characters in a story, the tone of a text, or the function of a code snippet.

o Influence style and quality: The wording, examples, and format of your prompt can guide the AI towards a specific style and level of quality.
Different types of prompts:
o Instructions: Clear and direct commands like "Write a haiku about a cat." o Questions: Open-ended questions to spark creativity, like "What would happen if robots ruled the world?"
o Data: Providing examples or references for the AI to learn from, like specific poems or code libraries.
Tips for effective prompts: 

o Be clear and specific: The more specific you are, the better the AI understands your request.
o Provide context: The more information you give, the richer and more relevant the output will be.
o Experiment with different styles: Try different wording and examples to see what works best.
o Use examples: Show the AI what you like by providing examples of desired outputs.
o Keep it concise: While providing context, avoid lengthy narratives that might confuse the AI.
Remember:

o Mastering prompts takes practice and experimentation.
o Different AI models might respond better to specific prompt styles. o Use prompts ethically and responsibly, being mindful of potential biases and

limitations.
By understanding and crafting effective prompts, you can unlock the full potential of generative AI and turn your ideas into reality!

Prompts examples of Nodejs , python and Java Node.js Prompts 

@workspace /new Create a new Node.js application with a sumTwoNumbers

function and Jest test cases. 

@workspace /new Create a new Node.js application withaddNumbers, subtractNumbers, multiplyNumbers, and divideNumbers functions, along

with Jest test cases. 

File Management System in Nodejs:
@workspace /new Develop a Nodejs application for file operations like creating, reading, updating, and deleting files. Include functions to perform these operations on files. Write jest test cases to ensure the proper functioning of file operations.

Weather Forecast Application in Nodejs:
@workspace /new Design a Nodejs app to fetch weather data from an API (e.g., OpenWeatherMap, WeatherAPI). Implement functions to retrieve current weather, weekly forecasts, and historical data based on user input. Create jest test cases to verify the accuracy of the retrieved weather information.

User Authentication System in Nodejs:
@workspace /new Develop a Nodejs application with user authentication functionalities such as signup, login, and logout. Utilize libraries like bcrypt or Passlib for password hashing. Implement token-based authentication and write jest test cases to ensure security and functionality.

To-Do List Manager in Nodejs:
@workspace /new Build a Nodejs app for managing a to-do list. Include functions for adding tasks, marking them as completed, deleting tasks, and listing all tasks. Write jest test cases to validate the addition, deletion, and completion of tasks in the to-do list.

Ptyhon prompt examples
Github Copilots Python Prompts 

@workspace /new Create a new Python application withaddNumbers, subtractNumbers, multiplyNumbers, and divideNumbers functions, along

with unit test cases.
Basic Calculator in Python:
@workspace /new Create functions for addition, subtraction, multiplication, and division operations. Implement error handling to handle division by zero scenarios. Write pytest test cases to validate the correctness of each operation.

File Management System in Python:
@workspace /new Develop a Python application for file operations like creating, reading, updating, and deleting files. Include functions to perform these operations on files. Write pytest test cases to ensure the proper functioning of file operations.

Weather Forecast Application in Python:
@workspace /new Design a Python app to fetch weather data from an API (e.g., OpenWeatherMap, WeatherAPI). Implement functions to retrieve current weather, weekly forecasts, and historical data based on user input. Create pytest test cases to verify the accuracy of the retrieved weather information.

User Authentication System in Python:
@workspace /new Develop a Python application with user authentication functionalities such as signup, login, and logout. Utilize libraries like bcrypt or Passlib for password hashing. Implement token-based authentication and write pytest test cases to ensure security and functionality.

To-Do List Manager in Python:
@workspace /new Build a Python app for managing a to-do list. Include functions for adding tasks, marking them as completed, deleting tasks, and listing all tasks. Write pytest test cases to validate the addition, deletion, and completion of tasks in the to-do list.

Java Prompts
o @workspace /new Create a new Spring Boot project with a REST API for managing students. 

▪ Use an in-memory H2 database for thestudents table. ▪ Implement the following endpoints:GET, POST, and DELETE.

▪ with student field id,name,age,marks
▪ with app name spring-boot-rest-api 

Creating UML diagram using Github Copilot

You can create Plant uml diagram using github copilot. (You can create diagram code in any ide, vscode , intellij or pycharm)
Please follow below steps for vs code here (I also provided screenshot) 

o Open Visual Studio Code: Launch Visual Studio Code now that you have both Visual Studio Code and GitHub Copilot installed.
o Open a New or Existing File: Open a new or existing file in Visual Studio Code where you want to create your PlantUML diagram.
o Activate Copilot: As you start typing PlantUML code, GitHub Copilot will automatically analyze what you're writing and offer suggestions based on context.
o Start Writing PlantUML Code: Begin typing your PlantUML code. As you do so, GitHub Copilot will provide suggestions for completing your code based on the patterns it has learned from its training data.
o Accept Copilot Suggestions: As you type, Copilot will suggest completions. You can accept these suggestions by pressing the Tab key or clicking on them with your mouse.
o Refine and Modify: If needed, you can refine or modify the suggestions provided by Copilot to better fit your requirements. This might involve adjusting parameters, changing diagram structures, or adding additional elements.
o Preview PlantUML Diagram: Utilize the live preview feature provided by the PlantUML extension to visualize your diagram directly within Visual Studio Code. This can help you ensure that your diagram looks as expected as you write and modify your code.
o Save and Export: Once you're satisfied with your PlantUML diagram, save your file. You can then export the diagram to various formats (such as PNG, SVG, or PDF) using the PlantUML extension or other tools, depending on your needs.
By following these steps, you can leverage GitHub Copilot within Visual Studio Code to expedite the process of creating PlantUML diagrams, while still having the flexibility to review and adjust the generated code as necessary.

Lets try using VS code
Create a file named diagrams.puml [image: ][image: ]After Accepting code please ritht click and in the menu select Preview Current Diagram [image: ]It will generate diagram on the right side as shown below
[image: ]

Github Copilot and Sql Queries

Github copilot can help in writing sql queries. You just need to create .sql file in any of the IDE (vscode,intellij or pycharm). Let's see example.
Open vscode and create a file queries.sql and in the file use ctrl + i
And try prompt like below and you will get the answer and accept it.
Give me simple employee table with columns id, name, salary
[image: ]Now in the follow up question please try below prompt
Give me query to find out the employee id and name with 6th highest salary
[image: ]Now what if I want query for particular db e.g Oracle (you can try below)
Give me query to find out the employee id and name with 6th highest salary in oracle [image: ]

Exercises

1. Write a ddl statements Creating student table with id,name and total marks
2. Write a simple query to find out the name of the student who got 11th rank in the class
3. Give me same query for different database like, oracle,sql server,db2
4. Find the employee ID and name with the 6th highest salary
5. Calculate the average salary excluding the highest and lowest salaries
6. Find the department with the maximum number of employees
7. Calculate the moving average of sales over a rolling window of 3 months
8. Find the nth highest salary using OFFSET and FETCH NEXT
9. Calculate the total sales amount for each month in the current year
10. Find the customers who made purchases in all product categories
11. Find the cumulative sum of sales by month
12. Identify the employees who have the same salary as their manager
13. Find the top 3 best-performing sales representatives based on total sales amount

Try first three with yourself Answers from 4 to 13 are as below [image: ][image: ]

Creating Sample files using Github Copilot

Creating json data file

Goto vscode editor create a file named customer.json and using ctrl + i try below prompt and accept it.
Prompt 1 : create a sample customer json with id ,name, age,city with 5 customers [image: ]

Creating csv data file

Prompt 2 : generate a sample Student csv data with id ,name, total marks with 25 students [image: ]

Unit Testing with Github Copilot

Say for example you have file called functions.py where you add functions like add, remove,subtract and multiply like below
[image: ]And you want to write unit test cases then create a simple file call test_functions.py
And put comments as below # generate test cases for all the functions like add, subtract, multiply, divide, press enter 

And Github copilot will give suggestion like below, the press tab

[image: ]

If you feel any case is not working, then delete that line/test and give comments on that line and you will get the magic

Tip : Question and Answers using copilot

if you want to ask question then ask in comment and press enter you will get answer in next line as below
[image: ]

Thank you

So that's the end of the course. 

Thank you for the invaluable insights in the "GitHub Copilot for Developers: Tips and Tricks" course. Your expertise and clear explanations have equipped me with practical skills to enhance coding efficiency. Grateful for your dedication to fostering learning in the developer community.
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import subprocess
from datetime import datetime

def add_numbers(a, b):

This function takes two numbers as arguments and returns their sum.

return a + b

def filter_even_numbers(lst):

This function takes a list of numbers and returns a new list containing only the even numbers.

return [x for x in st if x % 2 = @]

def sort_data_in_reverse(data):

This function takes a list of data and returns a new list with the data sorted in reverse order.

return sorted(data, reverse=True)

def execute(command):

This function takes a command as an argument and executes it in the shell.

try:
subprocess.run(command, shell=True)

except Exception as e:
print(f"An error occurred while executing the command: {e}")

def get_current_datetime():

This function returns the current date and time.

return datetime.now()
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number_of _items = 10

temperature = 25.0
item_list = [1, 2, 3, 4, 5]
user_data = {*name’: 'John', ‘age': 30}

# Add inplementation to calculate_total function
def calculate_total(paranl, param2):
return paranl + param2

# Use the function
total = calculate_total(number_of_items, temperature)
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Looking at the code excerpts from the file code_review_variables.py, here are some suggestions:

1. The variable x is defined but not used anywhere else in the code. If t's not nesdled, consider removing it
to avoid unnecessary variables.

2. The variable tenp is also defined but not used. I its not needed, consider removing it
3. The variable 1st is defined but not used. f it's not needed, consider removing it
4. The variable data s defined but not used. If ts not needed, consider removing it

5. The function calculate_total is defined but doesn't have any implementation. You might want to
add the logic for this function.

6. The variable names x, temp, 1st, and data could be more descriptive. Good variable names make.
code easier to understand and maintain.
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-~ Query 6: Calculate the total sales amount for each month in the current year
SELECT MONTH(sales_date) AS month, SUM(sales_amount) AS total_sales

FROM sales_data

WHERE YEAR(sales_date) = YEAR(GETDATE())

GROUP BY MONTH(sales_date);

-~ Query 7: Find the customers who made purchases in all product categories

SELECT customer_id

FROM sales

GROUP BY customer_id

HAVING COUNT(DISTINCT product_category) = (SELECT COUNT(DISTINCT product_category) FROM products);

-~ Query 8: Find the cumulative sum of sales by month

SELECT sales_date, sales_amount,
SUM(sales_amount) OVER (ORDER BY MONTH(sales_date)) AS cumulative sales

FROM sales_data;

-~ Query 9: Identify the employees who have the same salary as their manager
SELECT e.employee_id, e.employee_name

FROM employee e

INNER JOIN employee m ON e.manager_id = m.employee_id

WHERE e.salary = m.salary;

-~ Query 10: Find the top 3 best-performing sales representatives based on total sales amount
SELECT employee_id, SUM(sales_amount) AS total_sales

FROM sales_data

GROUP BY employee_id

ORDER BY total_sales DESC

LIMIT 3;
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x =10
temp = 25.0
1st = [1, 2, 3, 4, 51

data = ('name’: 'John', ‘age': 30}

result = calculate_total(price, quantity)
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-- Query 1: Find the employee ID and name with the 6th highest salary

SELECT employee_id, employee_name, salary

FROM (
SELECT employee_id, employee_name, salary, DENSE_RANK() OVER (ORDER BY salary DESC) AS rank
FROM employee

) AS ranked

#ERE rank = 6;

-~ Query 2: Calculate the average salary excluding the highest and lowest salaries
SELECT AVG(salary) AS average_salary
FROM (
SELECT salary
FROM employee
ORDER BY salary
OFFSET 1 ROW
FETCH NEXT (SELECT COUNT(*) - 2 FROM employee) ROWS ONLY
) AS middle_salaries;

-~ Query 3: Find the department with the maximum number of employees
SELECT department_id

FROM (
SELECT department_id, ROW_NUMBER() OVER (ORDER BY COUNT(*) DESC) AS rank
FROM employee
GROUP BY department_id

) AS ranked

WHERE rank = 1;

-~ Query 4: Calculate the moving average of sales over a rolling window of 3 months
SELECT sales_date, sales_amount,

AVG(sales_amount) OVER (ORDER BY sales_date ROWS BETWEEN 2 PRECEDING AND CURRENT ROW) AS moving_average
FROM sales_data;

-~ Query 5: Find the nth highest salary using OFFSET and FETCH NEXT
SELECT DISTINCT salary

FROM employee

ORDER BY salary DESC

OFFSET n-1 ROWS

FETCH NEXT 1 ROW ONLY;
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from datetime inport datetime

def xyz(a, b):
return a + b

def_proc(lst):
return [x for x in st if x % 2

def stuff(data):
return sorted(data, reverse=True)

def. execute(comand)
subprocess. run(command, shell=True)

def eunQ);
return datetime.now()
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ject? [Github-Copilot-Examples] C:\Us ifr‘u unittest import TestCase

2 from functions import add, subtract, multiply, divide, greet
s
4 # generate test cases for all the functions like add, subtract, multiply, divide, and greet
5
6> class TestFunctions(TestCase):
:;“"” 7 les test_add(se1f):
= self.assertEqual (add(16, 5), 15)
p—— self.assertEqual(add(10, -5), 5)
e self.assertEqual(add(16, 0), 10)

self.assertEqual(add(-16, -5), -15)
self.assertEqual(add(e, 6), 6)

def test_subtract(self):
self.assertEqual (subtract (10, 5), 5)
self.assertEqual (subtract (18, -5), 15)
self.assertEqual (subtract (10, 6), 16)
self.assertEqual (subtract(-10, -5), -5)
self.assertEqual (subtract(e, 6), 0)

def test_multiply(self):
self.assertEqual (nultiply(16, 5), 56)
self.assertEqual (nultiply(10, -5), -50)

self.assertEqual (nultiply(10, ), 0)
1£ ssertEaunt (multinlu(-18 -5) 50)
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public class App {

©  // question 1: what is the libarary used to connect to the database in spring boot?
& // answer 2 : spring-boot-starter-data-jpa

] public static void main(string[] args) {
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Usages

def_subtract(a, b):

return a - b

7 usages

def myltiply(a, b):

o ® peturn a % b
6usages

“def divide(a, b):

@ returna /b

# call the functions and print the results
print(add( = 10, b 5))_# 15
print(subtract( = 18, b 5)) #5
print(nultiply( = 10, b5)) # 50
print(divide( a 18, b 5)) # 2.0
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